What are the system requirements for my computer?

Below are the minimum system requirements for users' personal computers:

  • Operating System: Microsoft Windows 7 or later (recommended) or Mac OSX
  • Web Browser: Microsoft Internet Explorer 11, Edge (latest), Chrome (latest), Firefox (latest), or Safari (latest)
  • Tablets/Mobile Devices: Microsoft Surface Pro 2 or later 
  • iOS, Android, and Windows RT tablets and mobile devices are not officially supported, but should work with limited file-editing capability.
  • Microsoft Word 2010 or later (desktop version)
  • Microsoft Excel 2010 or later (desktop version)
  • Broadband Internet connection
  • Up-to-date, standard, anti-virus software—such as Norton or McAfee

If you are using a server running terminal services, it will require the installation of the extendedReach plugin on the server and for it to be available to all users. Here's a video on how to install the plugin: https://vimeo.com/82336233

Click here to download the plugin. 

Still need help? Contact Us Contact Us